Jump to content


Search the Community

Showing results for tags 'Frosting'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Reaper Discussion
    • FAQs 'n Stuff
    • News
    • Reaper General
    • RVC: Reaper Video Channel
    • Chronoscope
    • Bones Miniatures & Legendary Encounters
    • ReaperCon
  • Craft Corner
    • Show Off
    • Painting Tips & Advice
    • Works In Progress
    • Shutterbug
    • Sculpting
    • Speed / Army / Tabletop Techniques
    • Conversions, Presentation, and Terrain
    • Mini Exchanges and Paint Contests
  • Reaper Games
    • CAV
    • Warlord
  • General Discussion
    • General Fantasy
    • General Sci-Fi
    • General Modern / Historical
    • Kickstarter
    • Off-Topic Rampancy
  • The Sandbox
    • The Gathering
    • The Playing
    • Fiction, Poetry, and Other Abuses

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Harrek

    Figure Protecting

    So I finished a few figures that I had been working on. They are for tabletop and will get a lot of handling. So I want to protect them. Got a can of Purity Seal and used it. Now I have figures that look all frosted and like crap! Tell me someone knows a way to correct this? I shook the can very well. Applied a quick light coat. Did what I thought I was supposed to do and they look this way. So any guidance out there on what to do? And perhaps what I should be using? I'm about to chuck all of my hobby stuff across the room it makes me feel so sick.
  2. So, my dwarf looks like she got blasted by Takhisimat's white dragon head for a handful of d6's. I sprayed it with some matte sealer from The Armory and she frosted right up. It's been about 20 hours and it hasn't cleared at all. I did a search and read that applying some gloss sealant then re-applying matte sealer may fix this. Does anyone have any experience with this?
×