Jump to content

Bugs in the Force Creator Program


Recommended Posts

I believe I found some bugs in the force Creator program.  It appears that on user made files that contain only one type of weapons system (such as 2 x MRAC or 4 x PBG) with the piercing upgrade, the force manager neglects to add the points cost when it "imports" the file over, even though the points are accurately calculated on the constructor file and associated exported pdf. This only applies when you have ONE weapon type as opposed to multiple types of weapon groups - when you have say 2 x MRAC and 2 X PBG the program asks you to assign piercing to a particular weapon group).

 

Example: I created a Terran plane I named "Falcon Light Assault Fighter". Its overall TV is 162. For weapons it has LRACs X 2 with piercing. After saving, exporting to pdf and closing the the Creator, I then open up the Force Manager and create a Flight Squad, adding in a "Falcon Light Assault Fighter". It is coming up with all the same skills (even noting the piercing on the LRAC's) but comes up TV 156 (8 points short, which is correct math for piercing calculations as per the formulas in the book).

 

This same error came up on any given user file I made that had only 1 type of weapon system that also had piercing. Other models with this error had the appropriate value of points off to indicate piercing as the culprit of the bug. I did not find any points discrepancies in ANY other user made unit, regardless of combination, I've done.....and I've made about 50 different units spanning over 3 different races (I'm enjoying the hell out of the "design your own units" thing - best feature added to a miniature war game ever!).

Link to post
Share on other sites
  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

I am re-posting this here, since creating it's own section seems more appropriate:

 

 

Hello,

 

I believe I found a Bug in the Force manager. When constructing a Ritterlich Force with Lightning Warfare doctrine, the constructor applies Assault +1 for every weapon system a model has when it outputs the data to PDF (as opposed to Assault +1 only). Just wanted to throw that out there. Program rocks over all though - keep up the good work!

Link to post
Share on other sites

You can send issues with the programs directly to me at [email protected], that way we can jump on these as quickly as possible.

 

Can you send me some of the model files you you used to find the calculation issue? I have replicated the bug, but I'm seeing the problem whether weapons are mixed or not and would like to see what you are seeing, to better address the issue.

 

I posted in the other forum on the Lighting Warfare issue, but I'll ask here as well; Please send me the force file showing this problem.

 

 

Thank you very much,

 

Chris Lewis

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...